Score
0
Watch 58 Star 326 Fork 92

apioak / apioakLuaApache-2.0

安装依赖问题

Open
zhangchangwei  Opened this issue

输入图片说明

我已经安装了luarocks 2.4版本为什么安装apioak时还提示缺少

5504671 zanehy 1578987767 total 2 participants

Comments (3)

zhangchangwei 2020-06-02 17:08

进行了升级和缓存清理还是不行
yum --skip-broken update && yum clean all

[root@master1 soft]# yum install apioak-0.4.0-1.el7.x86_64.rpm
Loaded plugins: fastestmirror, langpacks
Examining apioak-0.4.0-1.el7.x86_64.rpm: apioak-0.4.0-1.el7.x86_64
Marking apioak-0.4.0-1.el7.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package apioak.x86_64 0:0.4.0-1.el7 will be installed
--> Processing Dependency: luarocks >= 2.3.0 for package: apioak-0.4.0-1.el7.x86_64
Loading mirror speeds from cached hostfile

  • base: mirrors.bfsu.edu.cn
  • extras: mirrors.bfsu.edu.cn
  • updates: mirror.bit.edu.cn
    --> Finished Dependency Resolution
    Error: Package: apioak-0.4.0-1.el7.x86_64 (/apioak-0.4.0-1.el7.x86_64)
    Requires: luarocks >= 2.3.0
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

其中luarocks也安装了(手动安装的)
[root@master1 soft]# luarocks

LuaRocks 2.4.1, a module deployment system for Lua

5504671 zanehy 1578987767
zanehy 2020-06-02 18:02 member

方便留一下联系方式吗?进行查看具体的问题。

zhangchangwei 2020-06-02 18:38

方便留一下联系方式吗?进行查看具体的问题。

@zanehy

QQ:975460284

Sign in to comment

Assignees
Labels
Not set
Projects
Milestones
Branches
Planed to start
Not set
Planed to end
Not set
Top level
Priority